Wednesday, June 27, 2007

Fedora: Frontech TV Tuner Card Installation

13/06/07- I cannot install my TV tuner card in fedora (this problem is irrelevant to my project, but i want it to be solved)
Symptoms:
I am unable to use my frontech TV tuner card model number jil-0606. Fedora cannot recognize this card.
Causes:
Its a cheap card and manufacture didn't provide the sufficient information on its EEPROM. So fedora cannot recognize it automatically and hence driver is not loaded.


Solutions tried:

1. From internet and using the commands dmesg and Lspci -v, i was able to figure out that it is saa7130 chip based card. The thing to do here is to figure out the card type and tuner number by yourself and load the modules .
2. But in fedora there are 108 cards with different tuner number number. The last tuner number I tried was 71 and the list was more than 71 I think. So I sticked to card number 3 and tried different variations of tuner number from 1 to 71. I used modprobe saa7134 card=3 tuner=x command where x is the tuner number.
I used dmesg after each modprobe to see what system the tuner belongs. I used TvTime to check whether these settings are working. After checking each module, i had to unload them by rmmod saa7134 command, so that the next module can be loaded.
3. I got the TV signals on tuner number 6,22,24,35,42,49 and 60. When i reached 71 it hanged.
4. The TV broadcasting system in India uses PAL B standard. But unfortunately there was not any standard in the tuner like that it was PAL or PAL_BG. Unfortunately the tuners on which I got the TV signal was of varying standards. They were:
6 - Temic NTSC
22 - Temic PAL/SECAM multi
24 - Philips PAL/SECAM multi
35 - Temic PAL_DK/SECAM_2
42 - Philips 1236D ATSC/NTSC Dual
49 - Microtune 4042 FI5 ATSC/NTSC Dual in
60 - Thomson DTT 761X(ATSC/NTSC)
One thing to note here is PAL_DK is as much as different to PAL as PAL to NTSC. In all the cases i was able to get only picture but no sound from my card. Also I was not able to scan the channels because there was a message 'No Frequency' in TvTime. So i guess the card number is not correct as well as the tuner number.
So in last 'm again where i started from. The main problem is the card itself. It doesn't specify sufficient about it in its EEPROM.
Solution:
Problem solved on 27/06/07
Actually the problem was tvtime software, which just couldn't recognize my card for my thousands of attempts. It's really thousand attempts, I wasted too much time for trying different cards and tuners. I installed kdetv that comes with fedora 7. First i tried different cards from my chosen 37 cards ( I identified the cards that have the same input as my Frontech card ) and tuner number 5. In first attempt I got only one channel that can be barely seen. Then i tried the card=17 tuner=37 and I got four channels with good picture. Then from channel configuration of kdetv I chose manual channel selection, didn't touch the maximum and minimum frequency and set the interval for searching 1MHz and I got all the channels.











But now I was not getting any sound. I again searched the internet and found the answer. I changed the card
number to 3 and everything get solved. I added the line options saa7134 card=3 tuner=37 in /etc/modprobe.conf so that the module will be automatically loaded at the boot time.

7 comments:

mann said...

Of course there is some stability problem, as sometimes when closing it, it doesn't close properly. The window will be gone but it will still be playing the sound. And you know that time you couldn't even shut down your system, you can't see the system-monitor, you cant see processes in terminal either. Because it all will hang. I think I got the solution and that is logout and login as root and start the kdetv again. Then close it properly. Logout and login as user again.

mann said...

I found out the better solution.... go to Settings - Configure kdetv -Sound and in Sound Properties box, Tick Mute mixer element on exit. Now the problem is solved forever.

mann said...
This comment has been removed by the author.
mann said...

There is some problem with the video4linux2 plug in in kdetv. So the option is to tick on the video4linux option instead of video4linux2 in video settings of kdetv.
http://www.linuxquestions.org/questions/showthread.php?t=358001

Anonymous said...

Thanks Guys for help
I was really able to use my tuner card in linux .
But after restarting my System , its not working properly .

Ramki said...

thank god u posted this online.
had a tough time. thanks and thanks a lot.

Buy Computer Online said...

TV tuner cards are very affordable.Good information have been shared in this article.
Buy usb cables online
TV tuner cards online